OctoSAM 1.10.1 Release

  • OctoSAM Release 1.10.1 is available for download


    Technical Documentation


    Supported Environments - minimum Requirements (no change from 1.10.0)

    Windows Scanner
    Windows Server 2008 R2 SP1

    Windows 7 SP1

    macOS Scanner Mac OS X 10.13 (High Sierra)
    Linux Scanner RHEL / CentOs 7
    Fedora 25
    SUSE 12
    Debian 9

    Ubuntu 16

    other distributions upon request

    OctoSAM Database SQL Server 2016 SP1
    OctoSAM Server Components Windows Server 2016
    .net Framework 4.8 64 bit required for License IIS Application and the OctoSAM GUI
    .net 5.0 64 bit required for all other Components
    OctoSAM GUI Windows 10 1809 / Windows Server 2016
    .net Framework 4.8 64 bit required



    New Features

    • Improved performance for License Manger Server analysis
    • Improved performance for License Manager tools and dialogs in the GUI
    • User can schedule an immediate Scan of a License Server from GUI
    • FlexLM monitor can now distinguish between used, checked-out and borrowed licenses
    • FlexLM scan properly parses more vendor specific variants
    • OctoSAM Monitor now provides an optional web interface (Beta)


    Removed Functionality

    • Scanning capabilites for LicenseManagerServers can no longer be limited per server. All capabilities supported by a License Manager Server type are always enabled.
    • Group scan via PowerShell script and Import Service is no longer supported. Use the integrated group scan in the OctoSAM import service.

    Breaking Changes for OctoSAM Monitor

    • In previous releases, FlexLM scan did support scanning of user names that contain spaces. This has been changed to an optional feature now which is disabled by default. If you have FlexLM license servers with usernames that contain spaces, you have to enable the corresponding option in the settings dialog of each affected FlexLM server.
    • LicenseManagers section in appsettings.json has been renamed to LicenseManagerServers. Type names have been adjusted for consistency. See the sample configuration file.

    Scan File Compatibility

    • The 1.10.0 import service supports reading 1.10.1, 1.10.0, 1.9.10 and 1.9.9. scan files. Import of older .scan files only partially supported for Windows systems with unsupported operating systems (Windows XP, Windows Vista) that cannot update to the newest scanner. Imported information may be incomplete for these systems.

    Update Instructions

    • Check the database migration script(s) for additional checks that you may have to run against the database before migration.
    • Stop OctoSAM services on the server
    • Stop IIS if you have deployed an IIS based module of OctoSAM
    • Make a backup copy of the database
    • Note that a direct migration from a Version other than 1.10.0 is not supported
    • Check the release notes of earlier versions for migration procedures
    • Make a backup copy of all configuration files
    • Optionally run the .MSI Installer for the GUI
    • Enable service broker on the database
    • Migrate the database schema with the supplied migration scripts
    • Check your current appsettngs.json settings with the new sample file
      Note that configuration keys in section LicenseManagerServers have been adjusted for consistency
    • Unzip the distribution archive and copy the Server folder to your designated location, usually D:\OctoSAM\Server
    • If you scan license management servers such as FlexLM, make sure the local tools are current. Use the newest tools provided by your servers.
    • Update standard queries and Reports from provided .zip file.
    • Start OctoSAM services
    • Note that the LicenseManagerServerObserverService must be started before creating or updating License Manager Server objects in the GUI
    • Update Octoscan2 windows scanner
    • Update the Mac and Linux Scanner(s)
    • Update other scanners and their start scripts. Note that the Powershell Modules are now in the Server folder, usually D:\OctoSAM\Server\Modules


    Known Limitations

    • DPI scaling is still experimental and does sometimes not work over RDP sessions, depending on the version of the server, the RDP client and DPI settings on the server.
    • FlexLM Diag scan supports only first configured vendor daemon, expiry date and other data scanned from diag is not available for other vendor daemons on the same FlexLM server.
    • Reports with more than 2000 different software packages selected fail due to a limit in SQL Server.