OctoSAM 1.9.4 Release

  • Can be downloaded from the file base.


    Supported Environments


    Octoscan2 Scanner Windows Server 2003, Windows XP or newer (32 and 64bit)
    (no change between 1.9.3 and 1.9.4)
    Database SQL Server 2012 R2 or newer.
    OctoSAM Server Components .net Framework 4.6.2 64 bit required
    OctoSAM GUI .net Framework 4.6.2. 64 bit required



    New Features

    • Repackaging information can now be collected per installation. For sites that tag software installations with special entries in the uninstaller registry, this information can now be collected per installation. This allows to locate installations that were not made using the official packages.
    • MAC address is now available directly in the machine object for Windows, Mac and ESX. In previous versions it was complicated to get the 'active at scan time' MAC address in the inventory for systems with multiple network adapters. Now the MAC address is reported by the scanners.
    • License manager server housekeeping has been improved
    • Powershell modules are now installed in the program folder and maintained with the .MSI. Placing the shell modules in the program folder protects them from unintentional modification and allows automatic update of the modules via .MSI installation.
    • VMWare ESX Scanner now supports PowerCLI 6.5 (Modules instead of Snapins)

    Removed Functionality

    • NetInstall Scanning has been removed from Octoscan2

    Update Instructions

    • Check your custom Queries/Reports for Changes in the Data Model that are not backward compatible:

      SoftwareSignature.Repackager
      SoftwareSignature.RepackagerInfo
      SoftwareSignature.RepackagerVersion

      have been removed. Use Columns in MachineSoftwareSignature instead.

      SoftwarePackage.LicensingRelevant

      has been removed. Use SoftwareLicensingType.LicensingRelevant instead.
    • Check the changed prerequisites: SQL Server 2012 R2 is required, .net Framework 4.6.2 is required
    • Make a backup copy of the database
    • Migrate to schema version 1.9.4 from 1.9.3. See release notes of 1.9.3 if you migrate from earlier versions.
    • Deploy the new Version of Octosocan2.exe to your environment .scan files are compatible with versions 1.8.16 or newer of the import Service
    • Stop OctoSAM services on the server
    • Make a backup copy of all configuration files
    • Run the .msi Installer
    • Merge the configuration settings with the new configuration template files.
      Be especially careful with the assembly binding redirect section of the configuration files. This section must exactly match the settings in the provided sample configuration files.
    • Update the software catalog from latest master file
    • Import Standard Queries and Reports from provided .zip file.
      Tests your custom queries with the new release.
    • Restart OctoSAM services
    • Update the VMWare vCenter scan start script - if used - according to sample provided in Support.zip
    • Update the AD Group scan start script - if used - according to sample provided in Support.zip


    Known Limitations

    • DPI scaling does sometimes not work over RDP sessions, depending on the version of the server, the RDP client and DPI settings on the server.
    • FlexLM Diag scan supports only first configured vendor daemon, expiry date and other data scanned from diag is not available for other vendor daemons on the same FlexLM Server.
    • Currently, the license manager statistics database does not allow more than 32767 issued licenses per server. Counts greater than that value will get truncated. "Unlimited" will also be converted to 32767
    • Group Settings Published Software Packages: Changes to the published Software Packages are immediately written to the database, cancel out of the dialog is ignored